This article helps you solve the problem that you cannot receive WhatsApp messages.
Problem
After integrating my WhatsApp account with CloudFon CX, I am unable to receive messages.
Cause
There are two possible reasons for the issue you are experiencing:
Your Twilio number is not enabled for WhatsApp.
The Webhook URL you are using is not correct.
Solution
Log in to your Twilio account.
Check in Twilio > Messaging > Senders > WhatsApp senders that your account has been approved.
If your account is already approved, check the Webhook URL for incoming messages.
Modify the Webhook URL as “https://messagingproxy.{company name}.io/{messaging proxy}/{unique key}/whatsapp/whatsapp:{phonenumber}”.
Use your account number in place of {phonenumber}.
Click Save.
To know about the messaging proxy URL, you can chat with us.