This article helps you solve the problem that you cannot send WhatsApp messages.
Problem
After integrating my Twilio WhatsApp account with Comm100CX platform, I am unable to send messages.
Cause
Once integrated, Twilio doesn't automatically add the required Area Code to the WhatsApp number when shared with Comm100CX platform. As a result, the outgoing messages from Comm100 CX platform fail to reach the customer.
For example, in the case of the Brazilian WhatsApp number, if your WhatsApp number is registered with an Area Code (11) as +55 11 4020024531267234 on Twilio, then, when shared with Comm100CX platform, is set to +55 4020024531267234.
Solution
You need to add an Area Code to the outgoing WhatsApp number to send WhatsApp messages from Comm100CX platform.
To add Area Code for a connected WhatsApp Business account, follow these steps:
Log in to your Comm100 CX platform Control Panel.
From the left navigation menu, go to Ticketing & Messaging Inbox > Channels > WhatsApp page.
On the Channel Account tab, go to the Operations column of the WhatsApp account and click Edit phone number to add Area Code.
On the Edit Phone Number popup, update the WhatsApp number to include the Area Code in the Phone number field.
Click Save.
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You can also verify the complete number with the Area Code from your Twilio. You must log in to Twilio Console fromhttps://www.twilio.com/login and navigate to Develop > Messaging > WhatsApp Senders.
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